A2 电子凸轮启动后 不动作的原因?

使用 A2 电子凸轮时,在伺服正常工作 的情况下,有时候明明该设定的参数都设了,凸轮却不动作,以下是一些经验的分享:

 步骤  可能原因  确认方法  解决方法
1  凸轮是否启  动  确认 P5-88.X0 是否设为1?  设为1凸轮才会运作!
2  主轴脉波未收到  1. 读取 P5-86 看是否有变化?  1. 检查编码器与伺服驱动器的接线

2. 若主轴脉波由 CN1 PLS/SIGN 脚接入,须于 P1-00 设定正确的脉波型式一般编码器都是 A/B 相的.

3 凸轮表无内容  1. 利用 AsdaSoft 读取凸轮表格观看是否都是0?

 

2. 凸轮表格倍率 P5-19 是否为0 ?

 1-1. 凸轮表格可能未执行烧录,重新上电后表格消失

1-2. 若由 HMI 触发伺服造表,请检查 HMI 程序

1-3. P5-81 指向的表格位置是否错误

2. P5-19 数值须设定正确,预设值为 1

 4   啮合条件没有发生  1. 先确认目前凸轮 位于哪一种 状态? 可读取 P5-88.S (最高位)来观察:

0:停止状态

1:啮合状态

2:前置状态

 1-1. 若 P5-88.S = 0,表示凸轮未啮合,请先确定 P5-88.Z (啮合条件)是否正确?

 

  • 如果Z=1(DI),必须确定 DI(0x36) CAM_ON是否有正确触发?
  • 如果Z=2(Capture),必须确定 CAP功能已开启,请检查 P5-36 ~ p5-39

1-2. 若 P5-88.S = 2 (前置状态),请往 步骤 5

1-3. 若 P5-88.S = 1 (啮合状态),请往 步骤 6

一直在前置区无法啮合  1. 前置量 P5-87 是否设定错误 ?

 

2. 主轴脉波方向 是负的 ?

 1. 在前置状态,需要收到 主轴脉波数 超过 P5-87 才会进入啮合状态,请确认此参数是否正确?

2-1. P5-87 具有正负号(有方向性),若设为正数,必须收到 正方向的主轴脉波;反之,则须收到负方向的主轴脉波.才能够把前置量抵消掉,凸轮才会啮合!由于 P5-87 习惯都设为正,所以主轴也必须为正方向,可观察 P5-86 数值是增大的,表示主轴方向为正

 

2-2. 若主轴脉波方向是负的,修改步骤为:

 

  1. 如果主轴来自前一台A2驱动器:可更改前一台A2的 P1-03 的检出器输出极性 即可
  2. 如果用 CN5 接 编码器:可将 P1-74.Z(光学尺回授方向) 更改即可!
  3. 如果用 CN1 接 编码器:必须更改配线,将A/B相 接线互换!!
  啮合后马上脱离  1. 脱离条件 P5-88.U=1,DI 已经 off?

2. 脱离条件 P5-88.U=2或6 且 啮合的长度 P5-89 太小?

 1. 可能 DI.CAM_ON 作用的时间太短,太快 Off 了!

2. 这会造成 凸轮虽然有啮合,但马上就脱离了.请检察 P5-89 是否设定错误!

 有啮合但速度很慢  1. 凸轮倍率 P5-19 太小

2. 凸轮週期 ( P5-84/P5-83 ) 数值太大

 1. 检查 P5-19 是否正确?

2. 在同样的主轴频率下,( P5-84/P5-83 ) 数值愈大,凸轮速度愈慢.请再确定此二参数是否正确?

------- 分享是一种美德,请于迴响加入本篇不足处,以嘉惠大众 ---------

参考:A2 电子凸轮常见问题


 


发表评论